UrbanPro
true

Learn CCNA Training from the Best Tutors

  • Affordable fees
  • 1-1 or Group class
  • Flexible Timings
  • Verified Tutors

Search in

Tunnel Configuration In Cisco Router

Sivaram
27/12/2017 0 0

Tunneling provides a mechanism to transport packets of one protocol within another protocol. The protocol that is carried is called as the passenger protocol, and the protocol that is used for carrying the passenger protocol is called as the transport protocol.

Generic Routing Encapsulation (GRE) is one of the available tunneling mechanisms which uses IP as the transport protocol and can be used for carrying many different passenger protocols.

The tunnels behave as virtual point-to-point links that have two endpoints identified by the tunnel source and tunnel destination addresses at each endpoint.

R1(config)# interface Tunnel1

R1(config-if)# ip address 172.16.1.1 255.255.255.0

R1(config-if)# ip mtu 1400

R1(config-if)# ip tcp adjust-mss 1360

R1(config-if)# tunnel source 1.1.1.1

R1(config-if)# tunnel destination 2.2.2.2

R2(config)# interface Tunnel1

 

R2(config-if)# ip address 172.16.1.2 255.255.255.0

R2(config-if)# ip mtu 1400

R2(config-if)# ip tcp adjust-mss 1360

R2(config-if)# tunnel source 2.2.2.2

R2(config-if)# tunnel destination 1.1.1.1

Since GRE is an encapsulating protocol, we adjust the maximum transfer unit (mtu) to 1400 bytes and maximum segment size (mss) to 1360 bytes. Because most transport MTUs are 1500 bytes and we have an added overhead because of GRE, we must reduce the MTU to account for the extra overhead. A setting of 1400 is a common practice and will ensure unnecessary packet fragmentation is kept to a minimum.

After configuring tunnel, two tunnel endpoints can see each other can verify using an icmp echo from one end.

R1# ping 172.16.1.2

0 Dislike
Follow 2

Please Enter a comment

Submit

Other Lessons for You

VLAN Class
Divides a Single Broadcast domain into Multiple Broadcast domains. By default, all ports of the switch are in VLAN1. VLAN1 is known as Administrative VLAN or Management VLAN or Native VLAN Controls...

Sandeep | 08/09/2020

0 0
0

IP ADDRESS
SLIDE

Akshay Gadling | 03/06/2020

1 0
0

OSI Model
CSMA or CD: The management of collision in the network can also be done with the implementation of Protocol – Carrier Sense Multiple Access or Collision Detection. This is a type of contention protocol...

Vijay Anandh | 26/05/2020

0 0
0

Why you need CCNA R&S certification?
Many students seek CCNA R&S training for the Cisco Certification. There is a dilemma within students whether to opt for these certifications or not.Over and above the College DegreeWe believe after...

What Is A Default Gateway?

Vishal Waghmare | 23/01/2018

0 0
0
X

Looking for CCNA Training Classes?

The best tutors for CCNA Training Classes are on UrbanPro

  • Select the best Tutor
  • Book & Attend a Free Demo
  • Pay and start Learning

Learn CCNA Training with the Best Tutors

The best Tutors for CCNA Training Classes are on UrbanPro

Book a Free Demo

UrbanPro.com is India's largest network of most trusted tutors and institutes. Over 55 lakh students rely on UrbanPro.com, to fulfill their learning requirements across 1,000+ categories. Using UrbanPro.com, parents, and students can compare multiple Tutors and Institutes and choose the one that best suits their requirements. More than 7.5 lakh verified Tutors and Institutes are helping millions of students every day and growing their tutoring business on UrbanPro.com. Whether you are looking for a tutor to learn mathematics, a German language trainer to brush up your German language skills or an institute to upgrade your IT skills, we have got the best selection of Tutors and Training Institutes for you. Read more